You are not logged in. Please login or register.


Post new reply

Post new reply

Compose and post your new reply

You may use: BBCode Images Smilies

All fields with bold label must be completed before the form is submitted.

Required information for guests


Required information

Topic review (newest first)

1

Bonsoir à toutes et à tous,

Je viens de finir la mise à jour d'Apache (de la version 2.2.23 vers la 2.2.26) et j'ai aussi fini d'écrire quelques patchs très interessants:

- désormais vous allez être capable de voir les erreurs suExec de vos scripts / cgis, tels que les suivants:
http://cgi.toad.lescigales.org/error500/info.php55 (répertoire en chmod 777)
et des erreurs que vous ne verrez probablement jamais smile telles que:
http://cgi.toad.lescigales.org/mismatch/info.php5
http://cgi.toad.lescigales.org/error500.bin

- un patch qui permet de choisir quelle version de PHP / Python utiliseront vos scripts (Ruby et Perl n'ont pas encore plusieurs versions d'installées).

Tous les sites existants avant l'upgrade ont été forcés à tourner sur la version 5.2 de PHP, tous les nouveaux sites tournent automatiquement sous PHP 5.5:

mysql> update vhosts set mimetypes = 'php:application/x-httpd-php5-2-fastcgi';
Query OK, 10614 rows affected (0.03 sec)
Rows matched: 10665  Changed: 10614  Warnings: 0

Vous pouvez retrouver les différents phpinfo() et versions des interpréteurs installés, ainsi que leurs extensions par défaut - si vous voulez jouer avec wink - à l'adresse suivante:

http://cgi.toad.lescigales.org/

Voilà, c'est tout pour ce soir, je finis de travailler sur une modification du control panel qui va vous permettre de changer la version de PHP faisant tourner votre site (pratique pour tester une mise à jour de vos sites).



Currently used extensions: pun_poll, pun_admin_manage_extensions_improved. Copyright © 2008 PunBB