Topic: Upgrade des versions PHP

Bonsoir à toutes et à tous,

Nous sommes actuellement occupés à mettre à jour notre serveur Apache afin de pouvoir vous permettre de personnaliser quelle version de PHP / Perl / Python le serveur lancera selon l'extension du fichier.

Cf ci-dessous pour un petit rappel de comment le faire via .htaccess.

L'ancienne version - qui consistait à écrire dans un .htaccess la configuration - qui restera fonctionnelle, va devenir déconseillée et vous aurez la possibilité de choisir quel langage relier à telle ou telle extension à partir du control panel.

Cette nouvelle méthode va nous permettre de mieux gérer les mises à jour de PHP / Perl / etc... sans forcer une upgrade des sites déjà présents sur lesCigales et utilisants une version antérieure des différents langages.

Les sites nouvellement créés sur lesCigales.ORG utiliseront automatiquement la dernière version de PHP et lors d'une mise à jour majeure de PHP, la dernière version compatible sera écrite dans la DB.

La bonne nouvelle c'est que dès que cette fonctionnalité est prête, nous pourrons vous autoriser à utiliser PHP 5.3, 5.4 et 5.5 smile

---

FAQ wrote:

Il vous suffit, dans un fichier .htaccess, de spécifier selon le format suivant

AddType [MIME-Type] [Extension]

quel interpréteur sera utilisé pour quelle extension.

Le type MIME définit quel interpréteur est utilisé et quelle action s'en suit:

application/x-httpd-php4 lance PHP4
    application/x-httpd-php4-source affiche la source du fichier PHP en utilisant l'interpréteur PHP4
    application/x-httpd-php5 lance PHP5
    application/x-httpd-php5-source affiche la source du fichier PHP en utilisant l'interpréteur PHP5
    application/x-httpd-perl lance Perl
    application/x-httpd-ruby lance Ruby
    application/x-httpd-python lance Python
    application/x-httpd-shell lance par défaut Bash

Exemples:


Faire en sorte que tous les scripts se terminant par .php soit lancés avec PHP5:

AddType application/x-httpd-php5 .php

Transformer vos fichiers .html en scripts PHP:

AddType application/x-httpd-php4 .html

Faire croire à tous que vous utilisez PHP alors qu'en fait, il n'en est rien:

AddType application/x-httpd-perl .php
lesCigales.ORG sysadm1n
L'hébergeur qui sent bon la lavande - Un control panel qu'il est chouette - Viendez nous parler!
"All that is necessary for evil to triumph is for good men to do nothing."

2

Re: Upgrade des versions PHP

Bonsoir,

J'ai vu il y quelques jours PHP5.6.0-dev dans la liste des possibles, mais sans l'extension MySQLi.
Avez-vous prévue de la rajouter ?

D.