1 Dernière modification par Sika (25-06-2014 14:25:24)

Sujet : Connexion "non permise"

Bonjour,
Je rencontre quelques problèmes pour me connecter à la BDD sur sql.lescigales.org.
Je ne m'y suis pas connecté depuis quelques mois et apparemment, je ne suis pas à jour sur les récents changements.

J'ai deux comptes/BDD pour mon site. Lorsque j'utilise le premier dont ce sert Joomla, j'obtiens l'erreur

 #2000 Connexion au serveur MySQL non permise

J'ai plusieurs fois généré un nouveau mot de passe, sans succès.

Cependant, ça fonctionne avec le second compte. Mais celui-ci ne me sert à rien (en passant, comment est-il possible de le supprimer ?).

Y'a-t-il eu un soucis lors de la mise à jour et mon mot de passe est mal enregistré ? Comment accéder de nouveau à ma base de données ?

D'avance merci

2

Re: Connexion "non permise"

Bonjour,

Pour supprimer votre compte, vous devez en faire la demande dans la catégorie Personel -> Préférences.
Ensuite concernant votre accès MySQL, avez vous bien stipulé 'localhost' comme hôte de connexion ? Selon le message d'erreur, je pense plutot qu'il s'agit d'un problème de connexion plus que d'un mauvais couple identifiant / mot de passe.

Il n'y a pas eu de mise à jour majeure au niveau de la base de données.

Bon courage

lesCigales.ORG sysadm1n
L'hébergeur qui sent bon la lavande - Un control panel qu'il est chouette - Viendez nous parler!
"All that is necessary for evil to triumph is for good men to do nothing."

3 Dernière modification par Sika (27-06-2014 10:45:28)

Re: Connexion "non permise"

Bonjour,
L'erreur intervient lorsque je tente de me connecter sur la page new.sql.lescigales.org.  Celle-ci ne permet pas de préciser l'hôte.
J'ai essayé sur adminer.sql.lescigales.org (en précisant localhost et le bon nom de BDD) et j'ai une autre erreur :

mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file

Apparement, il est conseillé de supprimer un flag dans un fichier côté serveur :-D

Merci de votre aide

4

Re: Connexion "non permise"

bonsoir,

Je n'est pas eu de problème pour me connecter sur adminer et phpmyadmin

pour adminer il n'est pas nécessaire de préciser une base de donnée, remplir juste utilisateur et mot de passe.

sinon, essayer au cas ou de changer le mot de passe de votre base de donnée, tuto : http://forum.lescigales.org/post8030.html#p8030

5

Re: Connexion "non permise"

Bonjour,
J'ai bien suivit le tuto, à plusieurs reprises mais rien n'y fait.
Est-il possible que vous regardiez dans les logs ?

6

Re: Connexion "non permise"

Bonsoir,

Apparement le message d'erreur stipule que votre mot de passe MySQL est trop vieux (l'ancien format est obsolète).
Avez vous essayé de passer par le control panel afin de regénérer un nouveau mot de passe pour votre base ?

Je pense que cela fixerait vos problèmes smile

Bonne soirée

lesCigales.ORG sysadm1n
L'hébergeur qui sent bon la lavande - Un control panel qu'il est chouette - Viendez nous parler!
"All that is necessary for evil to triumph is for good men to do nothing."

7

Re: Connexion "non permise"

Bonsoir,

Apparement le message d'erreur stipule que votre mot de passe MySQL est trop vieux (l'ancien format est obsolète).
Avez vous essayé de passer par le control panel afin de regénérer un nouveau mot de passe pour votre base ?

Je pense que cela fixerait vos problèmes smile

Bonne soirée

lesCigales.ORG sysadm1n
L'hébergeur qui sent bon la lavande - Un control panel qu'il est chouette - Viendez nous parler!
"All that is necessary for evil to triumph is for good men to do nothing."

8

Re: Connexion "non permise"

Ah j'ai répondu trop vite, apparement vous l'avez fait à plusieurs reprises, pourriez vous essayer de créer une nouvelle base de données ?

lesCigales.ORG sysadm1n
L'hébergeur qui sent bon la lavande - Un control panel qu'il est chouette - Viendez nous parler!
"All that is necessary for evil to triumph is for good men to do nothing."

9 Dernière modification par vier986 (26-08-2014 11:21:17)

Re: Connexion "non permise"

Je n'est pas eu de problème pour me connecter sur adminer et phpmyadmin.coque nexus 5 etui nexus 5 housse nexus 5

10

Re: Connexion "non permise"

toad a écrit:

Bonjour,

Pour supprimer votre compte, vous devez en faire la demande dans la catégorie Personel -> Préférences.
Ensuite concernant votre accès MySQL mutuelle entreprise, avez vous bien stipulé 'localhost' comme hôte de connexion ? Selon le message d'erreur, je pense plutot qu'il s'agit d'un problème de connexion plus que d'un mauvais couple identifiant / mot de passe.

Il n'y a pas eu de mise à jour majeure au niveau de la base de données.

Bon courage

Merci pour cette information, ma soeur voulait  supprimer le compte pas moyen.